Forum: General Topics

Forums / General Topics / GPS problem - Navicore SIRF III with Nokia N8, Tra...


Subject:GPS problem - Navicore SIRF III with Nokia N8, TrackMyJourney v0.8.1 



I have been using my Navicore SIRF III bluetooth GPS unit with my Nokia N8 for years now, currently with TrackMyJourney v0.8.1. Since earlier this week, I can't get my position anymore. The yellow dot appears in the bottom right hand corner of the screen, showing that my phone and GPS unit can see each other, but it doesn't turn green. If I look at the Clock in Display 7 (Gauge) this shows the correct date until my GPS unit connects, and then (today) it shows 11-Sep-2005. The Satellites Gauge shows 0 in use.
If I switch to using the internal GPS, my position is available, but I don't want to use that as it drains my battery and isn't terribly accurate.

Can anyone offer any advice? I've not yet tried the GPS unit with my PC - I suppose I'd have to find some software that would use it.



Surrey, UK

Phone Model:
BB 9800 Torch
BlackBerry 8900
SE W910i
Nokia 5800


Does the GPS have a removable battery or reset button? If so try disconnecting the battery for a few seconds or press the reset button. It might be that the GPS device has frozen and just needs a hard reset.

The fact that TMJ is showing a date (albeit wrong) does suggest that the device is sending a valid data stream via bluetooth (if the stream was corrupted then TMJ should reject it and would then just show the current date from the phones internal clock).

In fact I think 11/9/2005 rings a bell - I think I've seen the same date given from one of my old GPS devices before it establishes an initial fix, so it might be a default date built into the SIRF III chipset.

Any luck with the reset?



Bedfordshire, UK

Phone Model:
Sony Ericsson W770i, Blackberry Playbook(?)


I have the same GPS unit as you, and I can confirm what Stephen is saying.

On (quite rare) occasions, I have a similar problem, with the phone connecting to the GPS, but not getting a valid postion. I think there is somethign with the LEDs on the GPS unit that isn't quite right when this happens, but I can't quite remember what.

Anyway, the solution in my case has always been to just remove the battery from the GPS for 30s or so, then replace it, turn the GPS back on, and all seems to be well again.

Let us know if it worked for you (or if it didn't, if you managed to find a solution that did)



(You must be logged in to post a reply to this thread)