Forum: General Topics

Forums / General Topics / Sonim XP3300 with TMJ V 0.8.0, cannot find GPS sig...


Subject:Sonim XP3300 with TMJ V 0.8.0, cannot find GPS signal 



I just bought an XP3300 like you and install the TMJ. But my XP3300 cannot find the GPS signal. I saw someone that It's ok for XP3300 work with TMJ. I want to know what is the TMJ version that can be used and are there any special setting of TMJ for XP3300?

I tried 2 version:

Generic MIDP2.0/CLDC1.1, Standard (JAR): can run but cannot find GPS signal, I just can find "Bluetooth GPS" in GPS setting.

Generic MIDP2.0/CLDC1.1, With JSR-179 Internal GPS (JAR):Cannot run after install. Display "unsupported MIDlet".



I follow the Tutorial: Connecting to a GPS Device. But I cannot find the "Main Menu / GPS / GPS Options / Switch to xxx GPS" and "Main Menu / GPS / GPS Options / Basic Connection". It is only "BT buffer", "BT sleep time", "BT timeout", "reset to default"(grey), "BT/GPS connection sound", "use speed/bearing...", "use extra altitude..." in the Main Menu/GPS/GPS Option.

I have install the 3 Generic MIDP2.0/CLDC1.1 version
Standard: [JAD] [JAR], installed successfully, but cannot find the internal GPS option as mentioned in tutorial.
With JSR-179 Internal GPS: [JAD] [JAR], installed successfully, but run failure.
Without JSR-82 Bluetooth API: [JAD] [JAR], same as Standard version.

What do I miss?



Surrey, UK

Phone Model:
BB 9800 Torch
BlackBerry 8900
SE W910i
Nokia 5800

Hi xuxin,

Looking at the web server logs of other users with the XP3300, they look to be running the With JSR-179 Internal GPS version, so the problem really is why this particular version isn't running on your phone (it is only this version that has the Switch to xxx GPS menu option, which explains your second question at least).

I'm not able to test the XP3300 myself, so these are only ideas, but it might be worth trying the following:

- uninstall all versions of TMJ from the phone
- reboot the phone (remove the battery briefly)
- how did you install the JSR179 version before? ie, via the JAD or JAR file? Try installing via the other method from before

Check for any updates to the phone firmware. It looks like the other users are running firmware v9.1.0, if that helps (I don't know the exact procedure for checking the firmware on Sonim phones).

- ensure that the phone has a fair amount of free memory
- maybe try downloading the JAD and JAR files to your PC then transfer them to the phones memory card and install from there
- you say that the JSR179 installed successfully but doesn't run... Perhaps, after installation, look in the phones Application Manager (or the equivalent function on Sonim phones) and see if there are any security settings that can be set to 'Allow Access', maybe for the Internal GPS/Location Services in particular...

Any luck?




Thanks, Stephen

  I have tried the installed JSR179 version following your guide. But I run the TMJ failure again with the message "Unsupported MIDlet". Is there any elder JSR179 version? I think I can tried the elder one.



I think the gps is about similar to my XP 5300? (but I might be very wrong....) I've downloaded the version with internal gps, the lower part of the list of downloadable versions in the download screen. You have to switch the gps on in the settings menu. Works perfect on my Sonim.



Thanks, Visserman. I cannot find any GPS setting in my XP3300. I think it is open automated while the City Cruiser is running. The City Cruiser work ok in my XP3300

(You must be logged in to post a reply to this thread)