Forum: General Topics

Forums / General Topics / Int. GPS disconnects after 40 seconds


Subject:Int. GPS disconnects after 40 seconds 



I have TMJ version 0.7.8 loaded on my blackberry 9700 (v using the internal GPS. I'm just getting started but can’t get past a problem were the Application will connect to the int. GPS, get "int. GPS Signal OK" for about 40 seconds (give or take 1 second) and then goes to "Int GPS Signal Invalid". During the time the Int. GPS is connected I do receive GPS data before it cuts off and the data stops. I've read many postings on this forum and have tried all the recommendations but still the result doesn’t change. Anyone have any ideas on how to solve this?  TMJ looks like a very useful App but I can’t get past this issue to try it out.



Surrey, UK

Phone Model:
BB 9800 Torch
BlackBerry 8900
SE W910i
Nokia 5800


I'm not too sure about this, have you tried the following:

- Make sure no other apps are running at the same time (*shouldn't* make a difference but worth checking anyhow!). Best bet is to reboot the phone - use LeftCtrl+RightShift+Del is a quick way to do this.

- Are you outside with a good few of the sky? The 'Int GPS Signal Invalid' can come and go in normal use as you move in and out of areas of good/bad satellite reception, though if it consistently does it after 40 seconds that is a bit odd!

- Do you have any GPS errors in the log (Menu/Settings/Debug/View Event Log)?

- After it changes to 'Int GPS Signal Invalid' try minimising TMJ and checking the BlackBerry Options/Advanced/Location/Refresh GPS - does that give an up-to-date location? If so, in switching back to TMJ is it still stuck on Signal Invalid?

- Set the TMJ/GPS/Internal GPS Options to: Allow Costs: Ticked, Basic Connection: Unticked, Force 1 Sec Refresh: Unticked. (Restart after changing). Could you also try it with Allow Costs unticked as well.

Any luck?




Stephen, Thanks for the rapid reply. Well it looks like the Refresh GPS in the BB GPS menu solved the issue. finding the "Refresh GPS" was a little challenging. on the 9700 v5.*** the path is Options/Advanced Options/GPS Then press the menu key and then select "refresh GPS". now int. GPS stays locked on.

Thanks for your help. KSKI

(You must be logged in to post a reply to this thread)