Forum: General Topics

Forums / General Topics / Strangeness With TrackPoints.


Subject:Strangeness With TrackPoints. 



Bedfordshire, UK

Phone Model:
Sony Ericsson W770i, Blackberry Playbook(?)


Went out for a cycle in London (the Sky Ride) at the weekend, and noticed something slightly strange;

First of all, I noticed that my recorded distance seemed to be shrinking. I think that was because I had the number of track points set to 1000, and had roughly reached that number.
(So Q1 - is it the case that when the limit is reached, it will delete a bunch of old points to make room for the new ones, rather than being a case of 1 point out, 1 point in?)

In trying to rectify this, I accidently set the 'Max Track Points' to 'No Track' (misread it as No Track Limit)., so although it showed my position for the next stage of the trip, the total distance wasn't changing at all... (Doh!)

Anyway, to get to the main point, while it was set to 'No Track' but I already had some track storred, I quit TMJ, and restarted it. It then seemed as if the entire track had disapeared, until I changed the 'Max Track Points' back to a value, and quit and re-started TMJ a second time, then my track re-appeared, as if by magic.

Not a serious problem, but maybe this disapearing/reapearing track could be classed as a minor bug?? I guess it should show the track recorded up to the point the tracking was turned off?? Or maybe it is working as designed? Not exactly sure which the right way should be...

Anyway, over to you... 8o)





Surrey, UK

Phone Model:
BB 9800 Torch
BlackBerry 8900
SE W910i
Nokia 5800

Hi Chris,

Yes, when the trackpoint limit is reached TMJ will attempt to reduce the track size by 25% or so, rather than the one-in one-out idea. This is because removing points from the start of the track forces the entire track 'RecordStore' (the persistent copy of the track in the phone memory that is maintained when TMJ exits) to be recreated, which is a little too expensive to do on each new trackpoint.

The track disappearing and then reappearing when setting the Max Track to 'No Track' is I guess a slight bug, although in some ways it could be seen as a safety mechanism to prevent the track from accidentally being deleted, I'm not sure!!? The reason for it is that when setting the Max Track to 'No Track' the RecordStore is not cleared at this point. Even when restarting it is still not cleared, although no trackpoints are loaded due to the No Track setting. So, when subsequently increasing the trackpoints again the RecordStore is still available with the original trackpoints, and will load again on next startup. It is only the 'Menu/Clear/Clear Track' that completely removes the track and clears the RecordStore.

Overall, as you suggest, its perhaps more of a minor idiosyncrasy than a bug, so I think I'll probably leave it as is for the moment (ie, I'm feeling lazy!! ;-) but if you do find it a problem I can look into it further...




Bedfordshire, UK

Phone Model:
Sony Ericsson W770i, Blackberry Playbook(?)

Hi Stephen,
It's certainly not a problem for me, so don't spend any time on it on my account :o)
It just caused me a minor 'oh!' when my track vanished, and a slight 'phew!' when it re-appeared again.

All things considered, I'd rather it worked the way it does, than deleting my entire track 'by accident'.

As I said, don't bother changing anything on my behalf, I'm not sure how I'd want it to behave anyway...
However, if you are ever very bored, could I suggest this: If you start TMJ up, with the 'No Track' option, and there IS a track stored in memory, TMJ could pop up a message (at startup? or maybe a message on the Track text screen??) to the effect 'You have a storred track that will not be displayed due to the 'No Track' option being set' Then simple folk such as me would not get confused...!! 8o)


(You must be logged in to post a reply to this thread)